cron-aptからの次のようなエラーメッセージがrootに届いた場合の対処。

 
CRON-APT RUN [/etc/cron-apt/config]: Sun Dec 4 04:00:03 JST 2011
CRON-APT SLEEP: 1777, Sun Dec 4 04:29:42 JST 2011
CRON-APT ACTION: 0-update
CRON-APT LINE: /usr/bin/aptitude update -o quiet=2
Reading package lists…
W: Duplicate sources.list entry http://old-releases.ubuntu.com/ubuntu/ karmic/main i386 Packages
(/var/lib/apt/lists/old-releases.ubuntu.com_ubuntu_dists_karmic_main_binary-i386_Packages)
W: Duplicate sources.list entry http://old-releases.ubuntu.com/ubuntu/ karmic/restricted i386 Packages
(/var/lib/apt/lists/old-releases.ubuntu.com_ubuntu_dists_karmic_restricted_binary-i386_Packages)
W: Duplicate sources.list entry http://old-releases.ubuntu.com/ubuntu/ karmic/universe i386 Packages
(/var/lib/apt/lists/old-releases.ubuntu.com_ubuntu_dists_karmic_universe_binary-i386_Packages)
W: Duplicate sources.list entry http://old-releases.ubuntu.com/ubuntu/ karmic/multiverse i386 Packages
(/var/lib/apt/lists/old-releases.ubuntu.com_ubuntu_dists_karmic_multiverse_binary-i386_Packages)
W: Duplicate sources.list entry http://old-releases.ubuntu.com/ubuntu/ karmic-updates/main i386 Packages
(/var/lib/apt/lists/old-releases.ubuntu.com_ubuntu_dists_karmic-updates_main_binary-i386_Packages)
W: Duplicate sources.list entry http://old-releases.ubuntu.com/ubuntu/ karmic-updates/restricted i386 Packages
(/var/lib/apt/lists/old-releases.ubuntu.com_ubuntu_dists_karmic-updates_restricted_binary-i386_Packages)
W: Duplicate sources.list entry http://old-releases.ubuntu.com/ubuntu/ karmic-updates/universe i386 Packages
(/var/lib/apt/lists/old-releases.ubuntu.com_ubuntu_dists_karmic-updates_universe_binary-i386_Packages)
W: Duplicate sources.list entry http://old-releases.ubuntu.com/ubuntu/ karmic-updates/multiverse i386 Packages
(/var/lib/apt/lists/old-releases.ubuntu.com_ubuntu_dists_karmic-updates_multiverse_binary-i386_Packages)
W: Duplicate sources.list entry http://old-releases.ubuntu.com/ubuntu/ karmic-security/main i386 Packages
(/var/lib/apt/lists/old-releases.ubuntu.com_ubuntu_dists_karmic-security_main_binary-i386_Packages)
W: Duplicate sources.list entry http://old-releases.ubuntu.com/ubuntu/ karmic-security/restricted i386 Packages
(/var/lib/apt/lists/old-releases.ubuntu.com_ubuntu_dists_karmic-security_restricted_binary-i386_Packages)
W: Duplicate sources.list entry http://old-releases.ubuntu.com/ubuntu/ karmic-security/universe i386 Packages
(/var/lib/apt/lists/old-releases.ubuntu.com_ubuntu_dists_karmic-security_universe_binary-i386_Packages)
W: Duplicate sources.list entry http://old-releases.ubuntu.com/ubuntu/ karmic-security/multiverse i386 Packages
(/var/lib/apt/lists/old-releases.ubuntu.com_ubuntu_dists_karmic-security_multiverse_binary-i386_Packages)
W: You may want to run apt-get update to correct these problems

さっぱり解らなかったので、次のようなコマンドを打ってみたら、次の日からエラーがこなくなった。

 # sudo apt-get dist-upgrade

 

 

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です