XOOPSのmodule、「logcounterx」が、MySQL5.5.34でインストールが出来ない場合の対処方法。

XOOPSのmodule、logcounterxは、MySQL5.5.34,PHP5.4.23という環境で、インストールができませんでした。

しかし、諦めず、エラー情報から、解決方法を探っていくと、次の方法でインストールが可能と解りました。

xoopsのhtml内、moduleの中の、logcounterxのフォルダの中に、「sql」というフォルダがあります。

そこの中を見てみます。

# cd /home/USERDIR/public_html/html/xoops/modules/logcounterx/sql

# vi mysql.sql

として、次に置換をします。

TYPE = MyISAM」を、「ENGINE = MyISAM」に置換すれば、おk。

viエディターの場合には、下記のようにします。

「:%s/TYPE = MyISAM/ENGINE = MyISAM/gc」

と打ちまして、確認しながら、置換します。

保存し、もう一度、logcounterxをインストールしてみてください。

出来たかな?(^ω^)

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です